【题解】LightOJ1259 Goldbach`s Conjecture 线性筛

题目链接

Description

Goldbach’s conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1) Both a and b are prime

2) a + b = n

3) a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

Note

1.An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, …


我居然能想到n²的枚举……真是为我智商捉急

#include<cstdio>
const int N=1e7+10;
int t,prime[N/2],p,n,ca;
bool iscomp[N];
void primetable()
{
    for(int i=2;i<N;i++)
    {
        if(!iscomp[i])prime[p++]=i;
        for(int j=0;j<p&&prime[j]*i<N;j++)
        {
            iscomp[i*prime[j]]=1;
            if(i%prime[j]==0)break;
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    primetable();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int cnt=0;
        for(int i=0;prime[i]<=n/2;i++)
            if(!iscomp[n-prime[i]])cnt++;
        printf("Case %d: %d\n",++ca,cnt);
    }
    return 0;
}

总结

线性筛出素数之后直接暴力就好

猜你喜欢

转载自blog.csdn.net/qq_41958841/article/details/82729963
今日推荐