E - Goldbach's Conjecture

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

Every even number greater than 4 can be
written as the sum of two odd prime numbers.


For example:

8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.


Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input

The input will contain one or more test cases.
Each test case consists of one even integer n with 6 <= n < 1000000.
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

题意概括  :

将一个大于四的偶数,拆分生两个奇素数的和。

解题思路  :

首先筛法素数打表,将题目范围内的素数在一个数组中标记起来,然后找出从3开始相加等于n的两个素奇数,然后按所给样例形式输出.

#include<stdio.h>
#include<math.h>
#include<stdlib.h>

int prime[1000100];

int main()
{
	prime[0]=1;
	prime[1]=1;
	int n,i,j,k,flag;
	k = sqrt(1000100);
	for(i = 2;i <= k;i ++)
	{
		if(prime[i] == 0)
		for(j = i*2;j<=1000100;j += i)
		{
			prime[j] = 1;
		}
	}
	
	while(~ scanf("%d",&n))
	{
		if(n == 0)
		break;
		flag = 0;
		for(i = 3;i<=n;i ++)
		{
			if(prime[i] == 0&&prime[n-i]==0)
			{
				printf("%d = %d + %d\n",n,i,n-i);
				flag = 1;
				break;
			}
		}
		if(flag == 0)
		printf("Goldbach's conjecture is wrong.\n");
	} 
	
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81142684
今日推荐