Goldbach's Conjecture POJ - 2262 (素数筛)

E - Goldbach's Conjecture

 POJ - 2262 

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 

Every even number greater than 4 can be 
written as the sum of two odd prime numbers.


For example: 

8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.


Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

题意:每个偶数都可以由两个素数组成,给出一个偶数n(n>6),求出这个偶数可以有哪两个素数组成,如果有多个组合,取差最大的。

思路:素数筛预处理出前1e6的素数,然后从3到n/2枚举所有情况就可以了

#include "iostream"
#include "cstring"
using namespace std;
const int Max=1e6+10;
int prime[Max],is_prime[Max];
int main()
{
    memset(is_prime,0, sizeof(is_prime));
    is_prime[1]=1;
    for(int i=2,t=0;i<Max;i++){
        if(!is_prime[i]) prime[++t]=i;
        for(int j=1;j<=t&&i*prime[j]<Max;j++){
            is_prime[i*prime[j]]=1;
            if(!i%prime[j]) break;
        }
    }
    int n;
    while(cin>>n&&n){
        int i;
        for(i=3;i<=n/2;i+=2)
            if(!is_prime[i]&&!is_prime[n-i]) break;
        cout<<n<<" = "<<i<<" + "<<n-i<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41874469/article/details/81149546