数论_Goldbach`s Conjecture

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

Note

1.      An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, ...

判断小于等于n的素数是否合理存在

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e7;
int prime[5000000],ans = 0;
bool vis[maxn];
void judge()
{
	vis[1] = true;
	for(int i = 2; i < maxn;i++)
	{
		if(vis[i] == false)
		{
			prime[ans++] = i;
			for(int j = 2*i; j < maxn; j+=i)
				vis[j] = true;//quan bu s  
		}
	}
}
int main()
{
	judge();
	int n,cnt = 1;
	scanf("%d",&n);
	while(n--)
	{
		
		int temp,sum = 0;
		scanf("%d",&temp);
		for(int i =0; i < ans;i++)
		{
			if(prime[i]>temp/2)
				break;
			if(!vis[temp-prime[i]])
				sum++;
		}
		printf("Case %d: %d\n",cnt++,sum);
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/nothing_227/article/details/81133155