LightOj 1259 Goldbach`s Conjecture -------数论

Time limit   2000 ms

Memory limit   32768 kB

OS   Linux

Source   Problem Setter: Jane Alam Jan

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

Note

1.      An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, ...

题意:求n由几对素数相加而成。题目比较简单,直接素数打表即可判断。

#include <iostream>
#include <string.h>
#define maxn 10000005
using namespace std;
int prime[700005];
bool isprime[maxn];
int total;
void makeprime()
{
    memset(isprime,true,sizeof(isprime));
    memset(prime,0,sizeof(prime));
    total=0;
    isprime[1]=false;
    for(int i=2;i<=maxn;i++)
    {
        if(isprime[i])prime[total++]=i;
        for(int j=0;j<total&&i*prime[j]<=maxn;j++)
        {
            isprime[i*prime[j]]=false;
            if(i%prime[j]==0)break;
        }
    }
}
int main()
{
    int t,n;
    ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
    cin>>t;
    makeprime();
    int c=0;
    while(t--)
    {
        cin>>n;
        int ans=0;
            for(int i=0;prime[i]<=n/2&&i<total;i++)
                if(isprime[n-prime[i]])ans++;
            cout<<"Case "<<++c<<": "<<ans<<endl;
        
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sinat_41233888/article/details/81415655