poj2262 Goldbach's Conjecture(素数筛 水题)

日常水题传送门:Goldbach's Conjecture

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 

Every even number greater than 4 can be 
written as the sum of two odd prime numbers.
For example:
8  = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.


Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

题意:

将数字分解成两个素数和的形式,不存在就输出“Goldbach's conjecture is wrong.”。

思路:

直接分解素数,然后遍历即可

AC代码:

//#include <bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N = 1e6 + 7;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 + 7;
int prime[N],cnt;
bool isprime[N];
void get_prime()
{
    for(int i = 2;i < N;++i)
        if(!isprime[i]){
            prime[++cnt] = i;
            for(int j = i + i;j < N;j += i) isprime[j] = true;
        }
}
int main()
{
    get_prime();
    int n,pos;
    while(scanf("%d",&n) != EOF && n){
        bool flag = false;
        for(int i = 1;i <= cnt && (prime[i] << 1) <= n;++i){
            if(!isprime[n - prime[i]]){
                pos = i;
                flag = true;
                break;
            }
        }
        if(flag) printf("%d = %d + %d\n",n,prime[pos],n - prime[pos]);
        else printf("Goldbach's conjecture is wrong.\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41791981/article/details/82770782
今日推荐