A - Goldbach's Conjecture (埃氏筛法)

题目链接

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 

Every even number greater than 4 can be 
written as the sum of two odd prime numbers.


For example: 

8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.


Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

主要思想:题目大意为输入实数n,输出两个质数相加的形式,如果有多组,则输出质数差最大的一组。本题为多组数据输入,可以选择在一个函数中打出素数表。

埃氏筛法:

bool pri[1000001];//全局变量,初始值为0,表示素数
void prime(){
    for(int i=2;i<=1000000;i++){
        if(pri[i]==0){//i为素数
            for(int j=2;j*i<=1000000;j++)
                pri[i*j]=1;//将素数的倍数都标记为1
        }
    }
}

AC代码

#include<iostream>//埃氏筛选 A
using namespace std;
bool pri[1000001];
void prime(){
	for(int i=2;i<=1000000;i++){
		if(pri[i]==0){
			for(int j=2;j*i<=1000000;j++)
				pri[i*j]=1;
		}
	}
}
int main(){
	int n;
	prime();
	while(cin>>n&&n!=0)
	{
		bool flag=false;
		for(int i=2;i<=n/2;i++){
			if(pri[i]==0&&pri[n-i]==0)
			{
				cout<<n<<" = "<<i<<" + "<<n-i<<endl;
				flag=true;
				break;
			}
		}
		if(flag==false)
			cout<<"Goldbach's conjecture is wrong."<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/DEAR_CXN/article/details/88074291
今日推荐