HDU 1598 find the most comfortable road(并查集+枚举)

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9215    Accepted Submission(s): 3860


 

Problem Description

XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ),
但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。

 

Input

输入包括多个测试实例,每个实例包括:
第一行有2个正整数n (1<n<=200)和m (m<=1000),表示有N个城市和M条SARS。
接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000
然后是一个正整数Q(Q<11),表示寻路的个数。
接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。

 

Output

每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。

 

Sample Input

4 4 1 2 2 2 3 4 1 4 1 3 4 2 2 1 3 1 2

 

Sample Output

1 0

PS:首先按照边的速度从小到大排序,然后枚举。每次向集合中加入边,直到起点和终点在一个集合中,每次都要跟新最大差值。如果无法更新成功说明后面的边已经不能使起点和终点连接了,直接跳出。

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string>
#include<map>
#include<cmath>
#include<vector>
const int maxn=1e3+5;
const int mod=1e9+7;
const int inf=1e9;
#define me(a,b) memset(a,b,sizeof(a))
typedef long long ll;
using namespace std;
int root[maxn],n,m;
struct node
{
    int x,y,s;
    bool friend operator<(node a,node b)
    {
        return a.s<b.s;
    }
}a[maxn];
void inct()
{
    for(int i=1;i<=n;i++)
        root[i]=i;
}
int find(int x)
{
    if(x==root[x])
        return x;
    return root[x]=find(root[x]);
}
void un(int x,int y)
{
    int x1=find(x),y1=find(y);
    if(x1!=y1)
        root[y1]=x1;
}
int main()
{
	while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<m;i++)
            scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].s);
        sort(a,a+m);
        int t,ans;cin>>t;
        while(t--)
        {
            int x,y;scanf("%d%d",&x,&y);
            ans=inf;
            for(int i=0;i<m;i++)
            {
                inct();
                int flog=0,s=0;
                for(int j=i;j<m;j++)
                {
                    un(a[j].x,a[j].y);
                    if(find(x)==find(y))
                    {
                        flog=1,s=j;
                        break;
                    }
                }
                if(!flog)///没有路能够到达终点了
                    break;
                ans=min(ans,a[s].s-a[i].s);
            }
            if(ans==inf)
                cout<<"-1"<<endl;
            else
                cout<<ans<<endl;
        }
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41292370/article/details/81459933
今日推荐