HDU-1598 find the most comfortable road(枚举最小生成树)

HDU-1598 find the most comfortable road(枚举最小生成树)

原题链接:HDU-1598


XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure—超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ),
但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。

Input

输入包括多个测试实例,每个实例包括:
第一行有2个正整数n (1

Output

每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。

Sample Input

4 4
1 2 2
2 3 4
1 4 1
3 4 2
2
1 3
1 2

Sample Output

1
0

可以看出来的一道使用最小生成树的算法。他的最小差值也可以通过排序之后的枚举进行筛选,数据量也可以接受,所以我们只要枚举就完事了。

AC代码

@J1n9AB1n9

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
struct Edge
{
    int a,b,s;
} e[1010];
int f[210];
int n,m;
int Find(int x)
{
    if(x!=f[x]) f[x]=Find(f[x]);
    return f[x];
}
bool cmp(Edge x,Edge y)
{
    return x.s<y.s;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1;i<=m;i++) scanf("%d%d%d",&e[i].a,&e[i].b,&e[i].s);
        sort(e+1,e+1+m,cmp);
        int t;
        scanf("%d",&t);
        while(t--)
        {
            int Start,End,ans=0x3f3f3f;
            scanf("%d%d",&Start,&End);
            for(int i=1;i<=m;i++)
            {
                for(int j=1;j<=n;j++) f[j]=j;
                for(int j=i;j<=m&&e[j].s-e[i].s<ans;j++)
                {
                    int u=Find(e[j].a);
                    int v=Find(e[j].b);
                    f[u]=v;
                    if(Find(Start)==Find(End)){ans=e[j].s-e[i].s;break;}
                }
            }

            if(ans>=0x3f3f3f) printf("-1\n");
            else printf("%d\n",ans);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/J1nAB1n9/article/details/80725506