1146 Topological Order(25 分)

1146 Topological Order(25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg
Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

#include<iostream>
#include<cstdio>
#include<vector>

#define MAX 1000 + 10

using namespace std;

vector<int> MGraph[MAX];
int n,m,k;
int inDegree[MAX];
int tempDegree[MAX];
vector<int> res;
void copeDegree(){
    for(int i = 0; i < MAX; i++){
        tempDegree[i] = inDegree[i];
    }
}
bool topSort(vector<int> &vec){
    for(int i = 0; i < vec.size(); i++){
        int v = vec[i];
        if(tempDegree[v] == 0){
            for(int j = 0; j < MGraph[v].size(); j++){
                int t = MGraph[v][j];
                tempDegree[t]--;
            }
        }
        else return false;
    }
    return true;
}
int main() {
    cin >> n >> m;
    vector<int> ans;
    int a,b;
    for(int i = 0; i < m; i++){
        cin >> a >> b;
        MGraph[a].push_back(b);
        inDegree[b]++;
    }
    cin >> k;
    int v;
    for(int i = 0; i < k; i++){
        copeDegree();
        for(int j = 0; j < n; j++){
            cin >> v;
            res.push_back(v);
        }
        if(!topSort(res)) ans.push_back(i);
        while(!res.empty()) res.pop_back();
    }
    for(int i = 0; i < ans.size(); i++){
        if(i == 0) cout << ans[i];
        else cout << " " << ans[i];
    }
}

猜你喜欢

转载自blog.csdn.net/qq_39557517/article/details/81874608