1146 Topological Order (25 分)(拓扑排序)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8

1 2

1 3

5 2

扫描二维码关注公众号,回复: 15256995 查看本文章

5 4

2 3

2 6

3 4

6 4

5

1 5 2 3 6 4

5 1 2 6 3 4

5 1 2 3 6 4

5 2 1 6 3 4

1 2 3 4 5 6

Sample Output:

3 4

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
#include <unordered_set>
using namespace std;
int main() {
    int n,m;
    cin>>n>>m;
    vector<int> v[1010];
    vector<int> in(1010);
    for(int i=0;i<m;i++){
        int a,b;
        cin>>a>>b;
        v[a].push_back(b);
        in[b]++;
    }
    int k,flag1=0;
    cin>>k;
    for(int i=0;i<k;i++){
        vector<int> t=in;
        int temp,flag=1;
        for(int j=0;j<n;j++){
            cin>>temp;
            if(t[temp]) flag=0;
            for(int k=0;k<v[temp].size();k++)
                t[v[temp][k]]--;
        }
        if(flag==1) continue;
        printf("%s%d",flag1==1?" ":"",i);
        flag1=1;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42068614/article/details/87924852