1146 Topological Order (25分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4
#include<iostream>
#include<vector>

using namespace std;

int main(){

    int n, m;

    cin >> n >> m;
    // vector<int> in_graph[1001];
    vector<int> out_graph[1001];
    vector<int> pre_vec(n + 1);
    for(int i = 0; i < m; i++){

        int start, end;
        scanf("%d %d", &start, &end);
        out_graph[start].push_back(end);
        // in_graph[end].push_back(start);
        pre_vec[end]++;


    }

    int k;
    cin >> k;
    
    vector<int> out_result;
    for(int i = 0; i < k; i++){
        vector<int> temp_pre_vec(pre_vec.begin(), pre_vec.end());
        bool flag = true;
        vector<int> in_result(n);
        for(int z = 0; z < n; z++)
            scanf("%d", &in_result[z]);
            

        for(int z = 0; z < n; z++){

            int temp = in_result[z];

            if(temp_pre_vec[temp] > 0){
                flag = false;
                break;
            }
            for(int j = 0; j < out_graph[temp].size(); j++){

                temp_pre_vec[out_graph[temp][j]]--;

            }
            
            

        }
        if(!flag){
            out_result.push_back(i);
        }


        
    }
    printf("%d", out_result[0]);
    for(int i = 1; i < out_result.size(); i++)
        printf(" %d", out_result[i]);

    return 0;
}
发布了32 篇原创文章 · 获赞 0 · 访问量 434

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/104073831