PAT 1146 Topological Order(25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

思路:每次判断时用重新声明一个数组,存储度的信息。

程序:

#include <cstdio>
#include <iostream>
#include <vector>
#include <cstring>
using namespace std;
int edge[1001][1001];
int degree[1001];
bool isTopo(vector<int> v,int* deg)
{
  for(int i = 0; i < v.size(); i++)
  {
    if(deg[v[i]] == 0)
    {
      for(int j = 1; j <= v.size(); j++)
      {
        if(edge[v[i]][j])
          deg[j]--;
      }
    }
    else
        return false;
   }
  return true;
}
int main()
{
  int n,m;
  scanf("%d%d",&n,&m);
  for(int i = 0; i < m; i++)
  {
    int a,b;
    scanf("%d%d",&a,&b);
    edge[a][b] = 1;
    degree[b]++;
  }
  int k;
  scanf("%d",&k);
  vector<int> v;
  vector<int> cnt;
  for(int i = 0; i < k; i++)
  {
    v.clear();
    for(int j = 0; j < n; j++)
    {
        int point;
        scanf("%d",&point);
        v.push_back(point);
      }
     int arr[1001];
     memcpy(arr,degree,sizeof(degree));
     if(!isTopo(v,arr))
     {
        cnt.push_back(i);
     }
  }
  for(int i = 0; i < cnt.size(); i++)
  {
    if(i == 0)
      printf("%d",cnt[i]);
    else
      printf(" %d",cnt[i]);
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/hickey_chen/article/details/81131131