PAT 1146 Topological Order (25 分)

1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
在这里插入图片描述


Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.


Output Specification:
Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4




解析

#include<iostream>
#include<string>
#include<vector>
#include<cstdio>
#include<algorithm>
#include<set>
using namespace std;
vector<vector<int>> G;
vector<int> InDegree;
bool Topological(const vector<int>& top) {
	vector<int> In(InDegree.cbegin(), InDegree.cend());
	set<int> Q;
	for (int i = 1; i < In.size(); i++) {
		if (In[i] == 0)
			Q.insert(i);
	}
	auto it = top.begin();
	while (!Q.empty()) {
		if (Q.find(*it) != Q.cend()) {
			Q.erase(*it);
			for (auto x : G[*it]) {
				In[x]--;
				if (In[x] == 0)
					Q.insert(x);
			}
		}
		else
			return false;
		it++;
	}
	return it == top.cend();
}
int main()
{
	int N, M;
	scanf("%d %d", &N, &M);
	G.resize(N+1);
	InDegree.resize(N+1, 0);
	int v1, v2;
	for (int i = 0; i < M; i++) {
		scanf("%d %d", &v1, &v2);
		G[v1].push_back(v2);
		InDegree[v2]++;
	}
	int K;
	scanf("%d", &K);
	vector<int> top(N);
	vector<int> NOT;
	for (int i = 0; i < K; i++) {
		for (int i = 0; i < N; i++)
			scanf("%d", &top[i]);
		if (Topological(top) == false)
			NOT.push_back(i);
	}
	for (int i = 0; i < NOT.size(); i++) {
		printf("%d%c", NOT[i], i + 1 == NOT.size() ? '\n': ' ');
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/84870418