1146 Topological Order(25 分)(C++)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

用一个数组记录入度即可

#include <iostream>
#include <vector>
using namespace std;
std::vector<int> graph[1010],in(1010,0),tempin(1010);
int main(){
    int n,m,k;
    scanf("%d %d",&n,&m);
    for(int i=0;i<m;i++){
        int a,b;
        scanf("%d %d",&a,&b);
        graph[a].push_back(b);
        in[b]++;
    }
    scanf("%d",&k);
    bool f=true,flag;
    for(int i=0;i<k;i++){
        flag=true;
		tempin=in;
        for(int j=0;j<n;j++){
            int t;
            scanf("%d",&t);
            if(flag==false)
                continue;
            if(tempin[t]!=0)
                flag=false;
            for(int r=0;r<graph[t].size();r++)
                    tempin[graph[t][r]]--;
        }
        if(flag==false){
            if(f==false)
                cout<<' ';
            cout<<i;
            f=false;
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82502818