PAT Advanced 1146. Topological Order (25)

问题描述:

1146. Topological Order (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (<= 1,000), the number of vertices in the graph, and M (<= 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (<= 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4

只要按照拓扑排序的算法一步一步地验证就行;即设置一个出度和入度数组,每次在遇到顶点时,检查此顶点的入度是否为0,是则将所有此顶点指向的顶点入度减1,继续检查下一个,否则,输出序号。

AC代码:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
#include<bits/stdc++.h>
using namespace std;
vector<vector<int> > v;
int main()
{
  	ios::sync_with_stdio(false);
//	freopen("data.txt","r",stdin);
	int n,m,k,c1,c2,x;
	cin>>n>>m;
	v.resize(n);
	vector<int> vi(n,0);
	for(;m--;)
	{
		cin>>c1>>c2;
		c1--;
		c2--;
		v[c1].emplace_back(c2);
		vi[c2]++;
	}
	cin>>m;
	bool fp=true;
	for(int i=0;i<m;i++)
	{
		vector<int> vii=vi;
		int x,nn;
		bool flag=true;
		for(nn=n;nn--;)
		{
			cin>>x;
			x--;
			if(flag)
			{
				if(vii[x])
				{ 
					flag=false;
				} 
				else
				for(int i=0;i<v[x].size();i++)
				vii[v[x][i]]--;
			}
		}
		if(!flag)
		if(fp)
		{
			cout<<i;
			fp=0;
		}
		else
		cout<<" "<<i;
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/baidu_37550206/article/details/79705990