1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

根据输入的每一组数据判断是否是有向无环图的拓扑排序

#include<bits/stdc++.h>
using namespace std;
int main()
{

    int n,m,in[1005]={0};
    cin>>n>>m;
    vector<int>v[1005];
    for(int i=0;i<m;i++)
    {
        int t1,t2;
        cin>>t1>>t2;
        v[t1].push_back(t2);
        in[t2]++;
    }
    int k,x,a[1005]={0},num=0;
    cin>>k;
    for(int i=0;i<k;i++)
    {
        int flag=0;
        int tin[1005];
        memcpy(tin,in,sizeof(in));
        //cout<<tin[2]<<endl;
        for(int j=0;j<n;j++)
        {
            cin>>x;
            if(tin[x]==0)
            {
                for(int k=0;k<v[x].size();k++)
                    tin[v[x][k]]--;
            }
            else
                flag=1;
        }
        if(flag)
            a[num++]=i;
    }
    for(int i=0;i<num-1;i++)
        cout<<a[i]<<" ";
    cout<<a[num-1];
}
 

猜你喜欢

转载自blog.csdn.net/x_zjudream/article/details/86503672