PAT甲级1146 Topological Order(25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4
#include <iostream>
#include <bits/stdc++.h>

using namespace std;
int g[1024][1024];//图
int du[1024];//入度
int now[1024];//已经完成任务的前驱的个数,当其与入度相等时,该结点可以执行。
int main()
{
    memset(g, 0, sizeof(g));
    memset(du, 0, sizeof(du));
    int n, m;
    cin>>n>>m;
    for(int i=0; i<m; i++){
       int a, b;
       cin>>a>>b;
       g[a][b] = 1;
       du[b]++;
    }
    int k;
    cin>>k;
    int in = 0;
    int re[128];
    for(int u=0; u<k; u++){
        memset(now, 0, sizeof(now));
        int a[n+10];
        for(int i=0; i<n; i++){
            cin>>a[i];
        }

        for(int i=0; i<n; i++){
            if(now[a[i]] == du[a[i]]){完成任务的前驱的个数与入度相等时,该结点可以执行。
                for(int j=1; j<=n; j++){//注意这里是1~n,一开始写成了0~n-1......
                    if(g[a[i]][j] == 1){
                        now[j]++;//该结点所指向结点的完成任务的前驱的个数++
                    }
                }
            } else{
                re[in++] = u;
                break;
            }
        }
    }
    for(int i=0; i<in; i++){
        printf(i!=in-1?"%d ":"%d\n",re[i]);
    }
    return 0;
}
发布了88 篇原创文章 · 获赞 7 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Q_smell/article/details/81458387