1043 Is It a Binary Search Tree(25 分)

1043 Is It a Binary Search Tree(25 分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

解题思路:
判断给定序列是否是BST的前序或其镜像的前序序列,是则输出其后序序列。
按照算法笔记的方法,把这之中的前序、镜像前序、后序、镜像后序,全部得出,用vector存储。
直接比较vector数组。

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=1e3+10;

struct node{
    int data;
    node *lchild,*rchild;
};

void insert(node* &root,int x){
    if(root==NULL){
        root=new node ;
        root->data =x;
        root->lchild =root->rchild =NULL;
        return ;
    }else if(x<root->data ){
        insert(root->lchild ,x);
    }else{
        insert(root->rchild ,x);
    }
}
//前序 
void preorder(node *root,vector<int>&vi){
    if(root==NULL) return ;
    vi.push_back(root->data );
    preorder(root->lchild ,vi);
    preorder(root->rchild ,vi);
}
//镜像前序
void mpreorder(node *root,vector<int>&vi){
    if(root==NULL) return ;
    vi.push_back(root->data );
    mpreorder(root->rchild ,vi);
    mpreorder(root->lchild ,vi);
}
//后序
void postorder(node* root,vector<int>&vi) {
    if(root==NULL) return ;
    postorder(root->lchild ,vi);
    postorder(root->rchild ,vi);
    vi.push_back(root->data );
}
//镜像后序
void mpostorder(node* root,vector<int>&vi) {
    if(root==NULL) return ;
    mpostorder(root->rchild ,vi);
    mpostorder(root->lchild ,vi);
    vi.push_back(root->data );
}

vector<int>pre,post,mpre,mpost,ori;

int main(){
    int x,n;
    node *root=NULL;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&x);
        ori.push_back(x) ;
        insert(root,x);
    }
    preorder(root,pre);
    mpreorder(root,mpre);   
    postorder(root,post);
    mpostorder(root,mpost);
    if(ori==pre){
        printf("YES\n");
        for(int i=0;i<post.size() ;i++){
            printf("%d",post[i]);
            if(i<post.size() -1) printf(" ");
        }
    }else if(ori==mpre){
        printf("YES\n");
        for(int i=0;i<mpost.size() ;i++){
            printf("%d",mpost[i]);
            if(i<mpost.size() -1) printf(" ");
        }
    }else{
        printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chenyutingdaima/article/details/82050821
今日推荐