1043 Is It a Binary Search Tree (25 分) - C语言 PAT 甲级

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/huaxuewan/article/details/102408018

1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.
Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input:

7
8 6 8 5 10 9 11

Sample Output:

NO

题目大意:

输入有 N 个整数的序列,判断所给序列是否是搜索二叉树的前序遍历或其镜像的前序遍历;

若是输出 YES 和其后序遍历,若不是输出 NO;

设计思路:

默认此搜索二叉树,左子树小于根结点,右子树大于等于根结点

  1. 直接假设所给序列为搜索二叉树,递归子树建立后序遍历,建立过程中判断
    • 前序遍历的第一个值为根结点,左子树的值均小于根结点,右子树的值均大于等于根结点
    • 遍历过程中边界差值不为 1,则遍历失败
  2. 若不是,则假设序列为搜索二叉树的镜像,再次递归建立后序遍历
  3. 最后根据两次遍历结果输出
编译器:C (gcc)
#include <stdio.h>

int m = 0;
int post[1000] = {0};

void topost(int pre[], int root, int q)
{
        if (root > q) {
                return ;
        }

        int i = root + 1, j = q;
        while (i <= q && pre[root] > pre[i]) {
                i++;
        }
        while (j > root && pre[root] <= pre[j]) {
                j--;
        }

        if (i - j != 1) {
                return ;
        }
        topost(pre, root + 1, j);
        topost(pre, i, q);
        post[m] = pre[root];
        m++;
}

void topost2(int pre[], int root, int q)
{
        if (root > q) {
                return ;
        }

        int i = root + 1, j = q;
        while (i <= q && pre[root] <= pre[i]) {
                i++;
        }
        while (j > root && pre[root] > pre[j]) {
                j--;
        }

        if (i - j != 1) {
                return ;
        }
        topost2(pre, root + 1, j);
        topost2(pre, i, q);
        post[m] = pre[root];
        m++;
}

int main(void)
{
        int n, pre[1000];
        int i;

        scanf("%d", &n);
        for (i = 0; i < n; i++) {
                scanf("%d", &pre[i]);
        }

        topost(pre, 0, n - 1);
        if (m != n) {
                m = 0;
                topost2(pre, 0, n - 1);
        }
        if (m == n) {
                printf("YES\n%d", post[0]);
                for (i = 1; i < m; i++) {
                        printf(" %d", post[i]);
                }
        } else {
                printf("NO");
        }
        return 0;
}

猜你喜欢

转载自blog.csdn.net/huaxuewan/article/details/102408018