PAT 1043 Is It a Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

#include<iostream>
#include<cstdio>
#include<vector>

using namespace std;

struct node
{
    int data;
    node *left, *right;
};



void Insert(node* &root, int data)
{
    if(root == NULL) //如果到达空结点,即插入该点
    {
        root = new node;
        root->data = data;
        root->left =  NULL;
        root->right = NULL;
        return ;
    }
    if(data < root->data) //小于该点,则插入左结点
    {
        Insert(root->left, data);
    }
    else //大于该点,则插入右结点
    {
        Insert(root->right, data);
    }
}

void preOrder(node* root, vector<int>&vi)
{
    if(root == NULL)
        return ;
    vi.push_back(root->data);
    preOrder(root->left, vi);
    preOrder(root->right, vi);
}

void preOrderM(node* root, vector<int>&vi)
{
    if(root == NULL)
        return ;
    vi.push_back(root->data);
    preOrderM(root->right, vi);
    preOrderM(root->left, vi);
}

void postOrder(node* root, vector<int>&vi)
{
    if(root == NULL)
        return ;
    postOrder(root->left, vi);
    postOrder(root->right, vi);
    vi.push_back(root->data);
}

void postOrderM(node* root, vector<int>&vi)
{
    if(root == NULL)
        return ;
    postOrderM(root->right, vi);
    postOrderM(root->left, vi);
    vi.push_back(root->data);
}

//origin储存原始数组,pre、post分别储存先序后序,prem、postm储存镜像先序后序
vector<int> origin, pre, post, prem, postm;

int main()
{
    int n, data;
    node* root = NULL; //定义头节点
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
    {
        scanf("%d", &data);
        origin.push_back(data); //将数据存入origin中
        Insert(root, data); //将data插入二叉树中
    }
    preOrder(root, pre); //求先序
    preOrderM(root, prem); //求镜像先序
    postOrder(root, post); //求后序
    postOrderM(root, postm); //求镜像后序
    if(origin == pre) //如果原始序列等于先序虚列
    {
        printf("YES\n");
        for(int i = 0; i < post.size(); i++)
        {
            if(i != 0)
                printf(" ");
            printf("%d", post[i]);
        }

    }
    else if(origin == prem) //如果原始序列等于镜像先序虚列
    {
        printf("YES\n");
        for(int i = 0; i < postm.size(); i++)
        {
            if(i != 0)
                printf(" ");
            printf("%d", postm[i]);
        }

    }
    else
    {
        printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42819248/article/details/82793652
今日推荐