PAT--1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO
#include <iostream>
#include <bits/stdc++.h>

using namespace std;

struct TreeNode
{
    int data;
    TreeNode *left,*right;
};

void insertTree(TreeNode* &root,int x)
{
    if(root==NULL)
    {
        root = new TreeNode;
        root->data = x; //访问结构体指针的成员要用->,访问结构体的成员用.
        root->left= root->right = NULL;
        return;
    }
    else if(x<root->data)
        insertTree(root->left,x);
    else
        insertTree(root->right,x);

}

void preOrder(TreeNode* root,vector<int> &vi)
{
    if(root==NULL)
    {
        return;
    }
    vi.push_back(root->data);
    preOrder(root->left,vi);
    preOrder(root->right,vi);
}

void postOrder(TreeNode* root,vector<int> &vi)
{
    if(root==NULL)
    {
        return;
    }

    postOrder(root->left,vi);
    postOrder(root->right,vi);
    vi.push_back(root->data);
}

void preOrderMirror(TreeNode* root,vector<int> &vi)
{
    if(root==NULL)
    {
        return;
    }
    vi.push_back(root->data);
    preOrderMirror(root->right,vi);
    preOrderMirror(root->left,vi);

}

void postOrderMirror(TreeNode* root,vector<int> &vi)
{
    if(root==NULL)
    {
        return;
    }

    postOrderMirror(root->right,vi);
    postOrderMirror(root->left,vi);

    vi.push_back(root->data);
}
vector<int> origin,pre,post,preM,postM;//origin存放初始化序列,pre为先序,post为后序,preM为镜像先序,postM为镜像后序

int main()
{
    int n,data;
    TreeNode *root=NULL;//头结点

    cin>>n;

    for(int i=0; i<n; i++)
    {
        cin>>data;
        origin.push_back(data);
        insertTree(root,data);
    }

    preOrder(root,pre);
    postOrder(root,post);
    preOrderMirror(root,preM);
    postOrderMirror(root,postM);

    if(origin==pre)
    {
        cout<<"YES"<<endl;

        for(int i=0; i<post.size(); i++)
        {
            cout<<post[i];
            if(i<post.size()-1)
                cout<<" ";
        }
    }
    else if(origin==preM)
    {
        cout<<"YES"<<endl;

        for(int i=0; i<postM.size(); i++)
        {
            cout<<postM[i];
            if(i<postM.size()-1)
                cout<<" ";
        }
    }
    else
    {
        cout<<"NO";
    }
    cout<<endl;
    //cout << "Hello world!" << endl;
    return 0;
}

 注:建树时要先建左子树,因为左子树的判断条件是<,将其等于根节点的结点放到右子树上。

猜你喜欢

转载自blog.csdn.net/jackson_j/article/details/100034729