PTA A 1043 Is It a Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

#include<cstdio>
#define maxn 102
#include<algorithm>
#include<vector>
#include<cmath>
#include<iostream>
#include<queue>
using namespace std;
//任何一个序列,他都有一个对应的二叉查找树
//根据输入序列生成其对于的二叉查找树,对该树先序遍历,后序遍历,镜像先序遍历,镜像后序遍历并用vector存储
//比较结果即可
vector<int>origin,pre,post,premir,postmir;
struct node
{
    
    
    int data;
    node* lchild;
    node* rchild;
};
node* newnode(int x)
{
    
    
    node* Node=new node;
    Node->data=x;
    Node->lchild=NULL;
    Node->rchild=NULL;
    return Node;
}
void Insert(node*& root,int x)
{
    
    
    if(root==NULL){
    
    
        root=newnode(x);
        return;
    }
    if(x<root->data){
    
    
        Insert(root->lchild,x);
    }
    else{
    
    
        Insert(root->rchild,x);
    }
}
void preorder(node* root)
{
    
    
    if(root==NULL){
    
    
        return;
    }
    pre.push_back(root->data);
    preorder(root->lchild);
    preorder(root->rchild);
}
void preordermir(node* root)
{
    
    
    if(root==NULL){
    
    
        return;
    }
    premir.push_back(root->data);
    preordermir(root->rchild);
    preordermir(root->lchild);
}
void postorder(node* root)
{
    
    
    if(root==NULL){
    
    
        return;
    }
    postorder(root->lchild);
    postorder(root->rchild);
    post.push_back(root->data);
}
void postordermir(node* root)
{
    
    
    if(root==NULL){
    
    
        return;
    }
    postordermir(root->rchild);
    postordermir(root->lchild);
    postmir.push_back(root->data);
}
node* buildtree()
{
    
    
    node* root=NULL;//这里要注意要赋值为NULL,否则会死循环出错
    for(int i=0;i<origin.size();i++){
    
    
        Insert(root,origin[i]);
    }
    return root;
}
int main()
{
    
    
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
    
    
        int temp;
        scanf("%d",&temp);
        origin.push_back(temp);
    }
    node* root;
    root=buildtree();
    preorder(root);
    preordermir(root);
    if(origin==pre){
    
    
        postorder(root);
        printf("YES\n");
        for(int i=0;i<post.size();i++){
    
    
            if(i!=post.size()-1){
    
    
                printf("%d ",post[i]);
            }
            else{
    
    
                printf("%d",post[i]);
            }
        }
    }
    else if(origin==premir){
    
    
            postordermir(root);
            printf("YES\n");
            for(int i=0;i<postmir.size();i++){
    
    
            if(i!=postmir.size()-1){
    
    
                printf("%d ",postmir[i]);
            }
            else{
    
    
                printf("%d",postmir[i]);
            }
        }
    }
    else{
    
    
        printf("NO");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45890608/article/details/111345104
今日推荐