1043 Is It a Binary Search Tree(25 分)(C++)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题目大意:给定一个二叉树的先序遍历,判断是否为BST。

解题思路:采用DFS,以左子树小的二叉树为例,假定目前的子树先序遍历为(root,end),根节点肯定为root,那么他的左子树的先序的第一个为root-1,右子树的最后一个节点为end,从root+1开始遍历,得到的第一个大于或者等于root的值的节点即为右子树的第一个节点j,或者从end开始遍历,得到的第一个小于root的值的节点即为左子树最后一个节点i。必然有i-j等于1,如果不满足则说明非BST。

#include <iostream>
#include <vector>
using namespace std;
std::vector<int> pre,post;
int n;
bool flag;
void dfs(int root,int preend){
    if(preend<root)
        return;
    int i=root+1,j=preend;
    if(flag==false){
        while(i<=preend&&pre[i]<pre[root])
            i++;
        while(j>root&&pre[j]>=pre[root])
            j--;
    }
    else{
        while(i<=preend&&pre[i]>=pre[root])
            i++;
        while(j>root&&pre[j]<pre[root])
            j--;
    }
    if(i-j!=1)
        return;
    dfs(root+1,i-1);
    dfs(i,preend);
    post.push_back(pre[root]);
}
int main()
{
    scanf("%d",&n);
    pre.resize(n,-1);
    for(int i=0;i<n;i++)
        scanf("%d",&pre[i]);
    dfs(0,n-1);
    if(post.size()!=n){
        flag=true;
        post.clear();
        dfs(0,n-1);
    }
    if(post.size()!=n){
        printf("NO\n");
        return 0;
    }
    printf("YES\n");
    for(int i=0;i<n;++i){
        if(i!=0)
            printf(" ");
        printf("%d",post[i]);
    }
    system("pause");
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82111123