PAT A1043 Is It a Binary Search Tree (25分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805440976633856

题目描述
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

输入
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

输出
For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

样例输入
7
8 6 5 7 10 8 11

样例输出
YES
5 7 6 8 11 10 8

代码

#include<stdio.h>
#include<vector>
using namespace std;
struct node{
    int data;
    node *left,*right;
};
void insert(node* &root,int data){
    if(root == NULL){
        root = new node;
        root->data = data;
        root->left = root->right = NULL;
        return;
    }
    if(data < root->data){
        insert(root->left,data);
    }
    else{
        insert(root->right,data);
    }
}
void preOrder(node* root,vector<int> &vi){
    if(root == NULL){
        return;
    }
    vi.push_back(root->data);
    preOrder(root->left,vi);
    preOrder(root->right,vi);
}
void mirrorpreOrder(node* root,vector<int> &vi){
    if(root == NULL){
        return;
    }
    vi.push_back(root->data);
    mirrorpreOrder(root->right,vi);
    mirrorpreOrder(root->left,vi);
}
void postOrder(node* root,vector<int> &vi){
    if(root == NULL){
        return;
    }
    postOrder(root->left,vi);
    postOrder(root->right,vi);
    vi.push_back(root->data);
}
void mirrorpostOrder(node* root,vector<int> &vi){
    if(root == NULL){
        return;
    }
    mirrorpostOrder(root->right,vi);
    mirrorpostOrder(root->left,vi);
    vi.push_back(root->data);
}
vector<int> origin,pre,preM,post,postM;
int main(void){
    int n,data;
    node* root = NULL;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&data);
        origin.push_back(data);
        insert(root,data);
    }
    preOrder(root,pre);
    mirrorpreOrder(root,preM);
    postOrder(root,post);
    mirrorpostOrder(root,postM);
    if(origin == pre){
        printf("YES\n");
        for(int i=0;i<post.size();i++){
            printf("%d",post[i]);
            if(i != post.size() -1){
                printf(" ");
            }
        }
    }
    else if(origin == preM){
        printf("YES\n");
        for(int i=0;i<postM.size();i++){
            printf("%d",postM[i]);
            if(i != postM.size() -1){
                printf(" ");
            }
        }
    }
    else{
        printf("NO\n");
    }
    return 0;
}

发布了364 篇原创文章 · 获赞 13 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/105444529