1043 Is It a Binary Search Tree

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/yu121380/article/details/88836854

1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

解析:分别以最大和最小序建立两棵树,然后比较前序遍历与数据是否一致。注意建树时比较方式要对称

#include<set>
#include<map>
#include<list>
#include<queue>
#include<deque>
#include<cmath>
#include<stack>
#include<cstdio>
#include<string>
#include<bitset>
#include<vector>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<bits/stdc++.h>
using namespace std;

#define e exp(1)
#define p acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b) {
	return b?gcd(b,a%b):a;
}

vector<int> v,v1,v2,ans;
typedef struct TreeNode* Tree;
struct TreeNode {
	int data;
	Tree left;
	Tree right;
};

Tree creat1(Tree root,int num) {
	if(root==NULL) {
		root=(Tree)malloc(sizeof(struct TreeNode));
		root->data=num;
		root->left=NULL;
		root->right=NULL;
		return root;
	} else {
		if(num<root->data)
			root->left=creat1(root->left,num);
		else
			root->right=creat1(root->right,num);
	}
	return root;
}
Tree creat2(Tree root,int num) {
	if(root==NULL) {
		
		root=(Tree)malloc(sizeof(struct TreeNode));
		root->data=num;
		root->left=NULL;
		root->right=NULL;
		return root;
	} else {
		if(num<root->data)
			root->right=creat2(root->right,num);
		else
			root->left=creat2(root->left,num);
	}
	return root;
}

void preOrder(Tree root,vector<int> &v) {
	v.push_back(root->data);
	if(root->left)preOrder(root->left,v);
	if(root->right)preOrder(root->right,v);
}
void postOrder(Tree root,vector<int> &ans) {
	if(root->left)postOrder(root->left,ans);
	if(root->right)postOrder(root->right,ans);
	ans.push_back(root->data);
}
int n,x;
int main() {

	Tree root1=NULL,root2=NULL;
	scanf("%d",&n);
	for(int i=0; i<n; i++) {
		scanf("%d",&x);
		v.push_back(x);
		root1=creat1(root1,x);
		root2=creat2(root2,x);
	}

	preOrder(root1,v1);
	preOrder(root2,v2);

	if(v==v1) {
		printf("YES\n");
		postOrder(root1,ans);
		printf("%d",ans[0]);
		for(int i=1; i<ans.size(); i++) {
			printf(" %d",ans[i]);
		}
	} else if(v==v2) {
		printf("YES\n");
		postOrder(root2,ans);
		printf("%d",ans[0]);
		for(int i=1; i<ans.size(); i++) {
			printf(" %d",ans[i]);
		}
	} else printf("NO\n");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/yu121380/article/details/88836854