1043 Is It a Binary Search Tree (BST)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

  

注意:

  1. 函数的参数需要修改则需要传递引用
  2. 不要搞混 root=NULL 和 root=new node
  3. 注意镜像BST的特性,以及BST的前序遍历序列可以生成BST树
#include<cstdio>
#include<vector>
using namespace std;
vector<int> origin,pre,prem,post,postm;

struct node{
    int data;
    node *left,*right;
};

void insert(node* &root,int x){
    if(root==NULL){//root为空,需要申请空间 
        root=new node;
        root->data=x;
        root->left=root->right=NULL;
        return;//递归边界 
    }else{
        if(root->data<=x) insert(root->right,x);
        else insert(root->left,x);
    }
}

void preorder(node *root,vector<int> &v){
    if(root==NULL) return;
    v.push_back(root->data);
    preorder(root->left,v);
    preorder(root->right,v);
}

void preorderm(node *root,vector<int> &v){
    if(root==NULL) return;
    v.push_back(root->data);
    preorderm(root->right,v);
    preorderm(root->left,v);
}

void postorder(node *root,vector<int> &v){
    if(root==NULL) return;
    postorder(root->left,v);
    postorder(root->right,v);
    v.push_back(root->data);
}

void postorderm(node *root,vector<int> &v){
    if(root==NULL) return;
    postorderm(root->right,v);
    postorderm(root->left,v);
    v.push_back(root->data);
}

int main(){
    int n,t;
    node *root=NULL;//不要写成node *root= new node; 
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&t);
        origin.push_back(t);
        insert(root,t);
    }
    preorder(root,pre);
    preorderm(root,prem);
    postorder(root,post);
    postorderm(root,postm);
    if(origin==pre){
        printf("YES\n");
        for(int i=0;i<n;i++){
            printf("%d",post[i]);
            if(i<n-1)printf(" ");
        }
    }else if(origin==prem){
        printf("YES\n");
        for(int i=0;i<n;i++){
            printf("%d",postm[i]);
            if(i<n-1)printf(" ");
        }
    }else{
        printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/exciting/p/10428863.html
今日推荐