hdu1058Humble Numbers(丑数)

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29823    Accepted Submission(s): 13062

http://acm.hdu.edu.cn/showproblem.php?pid=1058
 

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

 

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

 

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

 

Sample Input

1

2

3

4

11

12

13

21

22

23

100

1000

5842

0

 

Sample Output

The 1st humble number is 1.

The 2nd humble number is 2.

The 3rd humble number is 3.

The 4th humble number is 4.

The 11th humble number is 12.

The 12th humble number is 14.

The 13th humble number is 15.

The 21st humble number is 28.

The 22nd humble number is 30.

The 23rd humble number is 32.

The 100th humble number is 450.

The 1000th humble number is 385875.

The 5842nd humble number is 2000000000.

题意:唯一的素数因子是2,3,5或7的数字称为简单数。 序列1,2,3,4,5,6,7,8,9,10,12,14,15,16,18,20,21,24,25,27 ......显示前20个不起眼数字。

编写程序以查找并打印此序列中的第n个元素
 

思路:丑数问题,见https://blog.csdn.net/qianchangdiyin/article/details/50787676

代码:

#include<iostream>
#include<cstring>
#include<cmath>
#include<iomanip>
#include<algorithm>
#include<cstdio>
#define inf 0x3f3f3f3f
using namespace std;


int minn(int a,int b,int c,int d)
{
    int min1=min(a,b);
    int min2=min(c,d);
    if(min1<min2)
        return min1;
    else
        return min2;
}

int main()
{
    int n;
    int p1,p2,p3,p4;
    p1=p2=p3=p4=1;
    int s[6000];
    s[1]=1;
    int i=1;
    while(i<=5842)
    { //此处不能写为if...else if ,因为有可能num[p2]*2==num[p3]*3==num[p5]*5==num[p7]*7
        s[++i]=minn(s[p1]*2,s[p2]*3,s[p3]*5,s[p4]*7);
        if(s[i]==s[p1]*2)
            p1++;
        if(s[i]==s[p2]*3)
            p2++;
        if(s[i]==s[p3]*5)
            p3++;
        if(s[i]==s[p4]*7)
            p4++;
    }
    while(cin>>n&&n)
    {
        if(n%10==1&&n%100!=11)
            cout<<"The "<<n<<"st humble number is "<<s[n]<<"."<<endl;
        else if(n%10==2&&n%100!=12)
            cout<<"The "<<n<<"nd humble number is "<<s[n]<<"."<<endl;
        else if(n%10==3&&n%100!=13)
            cout<<"The "<<n<<"rd humble number is "<<s[n]<<"."<<endl;
        else
            cout<<"The "<<n<<"th humble number is "<<s[n]<<"."<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sunny_hun/article/details/81806229