HDU-1058,Humble Numbers(丑数打表)

Problem Description:

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence 

Input: 

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n. 

Output: 

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output. 

Sample Input: 

1

2

3

4

11

12

13

21

22

23

100

1000

5842

Sample Output: 

The 1st humble number is 1.

The 2nd humble number is 2.

The 3rd humble number is 3.

The 4th humble number is 4.

The 11th humble number is 12.

The 12th humble number is 14.

The 13th humble number is 15.

The 21st humble number is 28.

The 22nd humble number is 30.

The 23rd humble number is 32.

The 100th humble number is 450.

The 1000th humble number is 385875.

The 5842nd humble number is 2000000000. 

解题思路: 

丑数是可以由2,3,5,7,因子组成的,应用丑数是2,3,5,7的倍数这一性质来做。从第一个丑数1开始,第二个丑数就是前面的丑数乘以2,3,5,7后得到的最小的那个值,就是2。 

程序代码:

#include<bits/stdc++.h>
using namespace std;
long long a[5843];
void check()
{
	int num=1;
	int p2,p3,p5,p7;
	p2=p3=p5=p7=1;
	a[1]=1;
	while(num<5843)
	{
		a[++num]=min(min(2*a[p2],3*a[p3]),min(5*a[p5],7*a[p7]));
		if(a[num]==2*a[p2])
			p2++;
		if(a[num]==3*a[p3])
			p3++;
		if(a[num]==5*a[p5])
			p5++;
		if(a[num]==7*a[p7])
			p7++;
	}
}
int main()
{
	check();
	int n;
	while(~scanf("%d",&n)&&n)
	{
		if(n%10==1&&n%100!=11)
			printf("The %dst humble number is %lld.\n",n,a[n]);
		else if(n%10==2&&n%100!=12)
			printf("The %dnd humble number is %lld.\n",n,a[n]);
		else if(n%10==3&&n%100!=13)
			printf("The %drd humble number is %lld.\n",n,a[n]);
		else
			printf("The %dth humble number is %lld.\n",n,a[n]);
	}
	return 0;
}
发布了274 篇原创文章 · 获赞 282 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/weixin_43823808/article/details/104060820