HDU1058 - Humble Numbers

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence 

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n. 

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output. 

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

思路:可知这是一道动态规划的题,所以我们要去找出其状态方程,可知大小是逐渐增加的,其由无限个因子组成,刚开始时

都是一个因子,则选出一个因子组成的数的最小值,可知是2,然后下次必须有两个因子2,然后再拿两个2因子组成的数和其他一个因子组成的数比较,选出最小的数,状态方程为f[t]=min(2*f[i],3*f[j],5*f[k],7*f[l]);

#include <iostream>
#include <stdio.h>
using namespace std;
int f[5843],n;
int i,j,k,l;
 
int min(int a,int b,int c,int d)
{
    int min=a;
    if(b<min) min=b;
    if(c<min) min=c;
    if(d<min) min=d;
 
    if(a==min) i++;
    if(b==min) j++;
    if(c==min) k++;
    if(d==min) l++;
 
    return min;
}
 
int main()
{
    i=j=k=l=1;
    f[1]=1;
    for(int t=2;t<=5842;t++)
    {
        f[t]=min(2*f[i],3*f[j],5*f[k],7*f[l]);
    }
    while(scanf("%d",&n)&&n!=0)
    {
        if(n%10==1&&n%100!=11)
            printf("The %dst humble number is %d.\n",n,f[n]);
        else if(n%10==2&&n%100!=12)
            printf("The %dnd humble number is %d.\n",n,f[n]);
        else if(n%10==3&&n%100!=13)
            printf("The %drd humble number is %d.\n",n,f[n]);
        else
            printf("The %dth humble number is %d.\n",n,f[n]);
    }
 
    return 1;
}
 

猜你喜欢

转载自blog.csdn.net/qq_41785863/article/details/81605696