HDU 1058 Humble Numbers(dp打表)

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29172    Accepted Submission(s): 12777


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
 
  
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
 

Sample Output
 
  
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

dp[i ]是第i个Humble number,那么它的2倍,3倍,5倍,7倍也是Humble number。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[5843];
void fun()
{
	dp[1]=1;
	int n=1;
	int p2=1,p3=1,p5=1,p7=1;
	while(dp[n]<2000000000)
	{//不能用if...else if...else if 
		dp[++n]=min(min(2*dp[p2],3*dp[p3]),min(5*dp[p5],7*dp[p7]));
		if(dp[n]==2*dp[p2])
			p2++;
		if(dp[n]==3*dp[p3])
			p3++;
		if(dp[n]==5*dp[p5])
			p5++;
		if(dp[n]==7*dp[p7])
			p7++;
	}//这里的p2,p3,p4,p5也代表了下标,每次保留当前最小的dp[p2],dp[p3],dp[p5],dp[p7]
	return;
 }
 int main()
 {
 	fun();
 	int n;
 	while(~scanf("%d",&n)&&n)
 	{//这题输出什么意思没搞懂 
 		printf("The %d",n);
 		int t=n/10%10;
 		if(n%10==1&&t!=1)
 			printf("st");
 		else if(n%10==2&&t!=1)
 		{
 			printf("nd");
		}
		else if(n%10==3&&t!=1)
 		{
 			printf("rd");
		}
		else
 		{
 			printf("th");
		}
		printf(" humble number is %d.\n",dp[n]);
	}
	return 0;
 }

猜你喜欢

转载自blog.csdn.net/bbhhtt/article/details/80377154