Humble Numbers (谦卑数 || 丑数)

版权声明:转载于[email protected]的博客 https://blog.csdn.net/nuoyanli/article/details/86151228

Humble Numbers

 题目来源:https://vjudge.net/contest/278033#problem/B || http://acm.hdu.edu.cn/showproblem.php?pid=1058

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence 

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n. 

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output. 

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

思路就是构造humble number (直接枚举肯定超时)坑点就是输出格式。。。。(还是要学好英语emmm)

ac代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define mm(a) memset(a,0,sizeof(a))
#define N 5900
#define min4(a,b,c,d) min(min(a,b),min(c,d))
using namespace std;
int dp[N];
int main()
{
    int n;
    char s1,s2;
    dp[1]=1;
    int a1=1,a3=1,a5=1,a7=1,t1,t2,l=2;;
    while(l<=5842)
    {
        dp[l]=min4(2*dp[a1],3*dp[a3],5*dp[a5],dp[a7]*7);//这应该是所谓的状态转移方程吧!!
        if(dp[l]==dp[a1]*2)
            a1++;
        if(dp[l]==dp[a3]*3)
            a3++;
        if(dp[l]==dp[a5]*5)
            a5++;
        if(dp[l]==dp[a7]*7)
            a7++;
        l++;
    }
//freopen("C:\\Users\\nuoyanli\\Desktop\\DATA.txt","r",stdin);
    while(cin>>n&&n)
    {
        if(n%10==1&&n%100!=11)
            s1='s',s2='t';
        else if(n%10==2&&n%100!=12)
            s1='n',s2='d';
        else if(n%10==3&&n%100!=13)
            s1='r',s2='d';
        else s1='t',s2='h';
        printf("The %d%c%c humble number is %d.\n",n,s1,s2,dp[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/nuoyanli/article/details/86151228