hdoj-1058-Humble Numbers【DP&】

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20715    Accepted Submission(s): 9045


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
 
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
 
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1024  1025  1081  1160  2870 
 

#include<stdio.h>
int dp[5900];
int min(int a,int b,int c,int d){
	int t1,t2;
	t1=a>b?b:a;
	t2=c>d?d:c;
	return t1>t2?t2:t1;
}
void f(){
	int f1,f2,f3,f4;
	f1=f2=f3=f4=1;
	dp[1]=1;
	for(int i=2;i<=5842;++i){
		dp[i]=min(dp[f1]*2,dp[f2]*3,dp[f3]*5,dp[f4]*7);
		if(dp[i]==dp[f1]*2) f1++;
		if(dp[i]==dp[f2]*3) f2++;
		if(dp[i]==dp[f3]*5) f3++;
		if(dp[i]==dp[f4]*7) f4++;
	}
}
int main(){
	f();
	int n;
	while(scanf("%d",&n),n){
		printf("The %d",n);
		if(n%10==1&&n%100!=11) printf("st");
		else if(n%10==2&&n%100!=12) printf("nd");
		else if(n%10==3&&n%100!=13) printf("rd");
		else printf("th");
		printf(" humble number is %d.\n",dp[n]);
	}
	return 0;
}


好题,刚开始没找到思路,看看别人的代码才明白,真是水啊尴尬

猜你喜欢

转载自blog.csdn.net/qq_18062811/article/details/47658137