HDU-1058-Humble Numbers

真是一道千古难题AAA!!!!!

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.
Write a program to find and print the nth element in this sequence

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

思路:变形素数筛+注意控制输出要求+时间复杂度O(1);

#include<iostream>
#include<algorithm> 
using namespace std;
long long a[5843],b[5843];
void find_num(){//类似于处理素数筛 
	int i;
	b[1]=a[1]=1;
	int i2,i3,i5,i7;
	i2=i3=i5=i7=1;
	for(i=2;i<=5842;i++){
		a[i]=min(min(min(a[i2]*2,a[i3]*3),a[i5]*5),a[i7]*7);
		if(a[i]==a[i2]*2) i2++;
		if(a[i]==a[i3]*3) i3++;
		if(a[i]==a[i5]*5) i5++;
		if(a[i]==a[i7]*7) i7++;
		b[i]=a[i];
	}
}
int main(){
	int n;
	find_num();
	while(1){
		cin>>n;
		if(n==0)
			break;
		else{
			if(n%10==1&&n%100!=11)
				cout<<"The "<<n<<"st "<<"humble number is ";
			else if(n%10==2&&n%100!=12)
				cout<<"The "<<n<<"nd "<<"humble number is ";
			else if(n%10==3&&n%100!=13)
				cout<<"The "<<n<<"rd "<<"humble number is ";
			else 
				cout<<"The "<<n<<"th "<<"humble number is ";
			cout<<b[n]<<"."<<endl;
		}
	}
}
发布了73 篇原创文章 · 获赞 27 · 访问量 1230

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/103837698