Number Sequence 【KMP查找字串第一次出现的位置】

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

寻找子串在母串中第一次出现的位置。

KMPcode:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int MAXN=1e6+20;
int nex[MAXN],a[MAXN],b[MAXN],n,m;
void getnex(){
	int i=1,j=0;
	nex[0]=0;
	while(i<m){
		if(b[i]==b[j]) nex[i++]=++j;
		else if(j==0) i++;
		else j=nex[j-1];
	}
}
int kmp(){
	int i=0,j=0;
	while(i<n && j<m){//m子串长度 
		if(a[i]==b[j]){
			i++;j++;
		} 
		else if(j==0) i++;
		else j=nex[j-1];
	}
	if(j==m) return i-m+1;//i-m+1
	return -1;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d %d",&n,&m);
		for(int i=0;i<n;i++) scanf("%d",&a[i]);
		for(int i=0;i<m;i++) scanf("%d",&b[i]);
		getnex();
		printf("%d\n",kmp());
	}
	return 0;
}

试了几次决定这样

int kmp(){
	int i=0,j=0;
	while(i<n && j<m){//m子串长度 
		if(a[i]==b[j]){
			i++;j++;
		} 
		else if(j==0) i++;
		else j=nex[j-1];	
		if(j==m) return i-m+1;//i-m+1 判断条件写在里面 ,while j<m 不写的话判断条件放在外面会错
	}

	return -1;
}

猜你喜欢

转载自blog.csdn.net/qq_41333844/article/details/81805833