HDU3342 Legal or Not【拓扑排序】

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10698    Accepted Submission(s): 5018


 

Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

 

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

 

Output

For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".

 

Sample Input

 

3 2 0 1 1 2 2 2 0 1 1 0 0 0

 

Sample Output

 

YES NO

 

Author

QiuQiu@NJFU

 

Source

HDOJ Monthly Contest – 2010.03.06

问题链接HDU3342 Legal or Not

问题简述:(略)

问题分析

  给定n个人及其m种关系,关系是师徒关系,问这种师徒关系是否矛盾(合法)。图形成循环的话,就矛盾了(不合法)。

  这个问题可以用拓扑排序的方法来解决,如果可以进行排序则没有矛盾,也就是所有节点都能够被输出的话则没有矛盾。

  节点规模虽然比较小,图也可以用采用邻接表来表示。

程序说明

  没有前驱的节点,可以排序输出,放入队列中,并且做个遍历标记。再用队列中的节点(已经可以输出)去除与其有边相连节点的前驱,直到不能操作为止。如果全部遍历,则没有循环即合法,否则不合法。

  所有节点是否被全部遍历,计数一下就可以做到。

  需要注意的是,程序中43行是必要的,预先分配向量数组,就不用每个元素一一处理了!

题记:(略)

参考链接:(略)

AC的C++语言程序如下:

/* HDU3342 Legal or Not */

#include <iostream>
#include <vector>
#include <queue>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 100;
vector< vector<int> > g;
int din[N];
int n, m;

bool toposort()
{
    queue<int> q;
    for(int i = 0; i < n; i++)
        if(din[i] == 0)
            q.push(i);

    int cnt = 0;
    while(!q.empty()) {
        int u = q.front();
        q.pop();
        cnt++;

        for(int i = 0; i < (int)g[u].size(); i++) {
            int v =g[u][i];
            if(--din[v] == 0)
                q.push(v);
        }
    }

    return cnt == n;
}

int main()
{
    while(~scanf("%d%d", &n, &m) && (n || m)) {
        g.clear();      // 图邻接矩阵
        g.resize(n);
        memset(din, 0, sizeof(din));    // 节点入度

        // 读入图
        for(int i = 1; i <= m; i++) {
            int u, v;
            scanf("%d%d", &u, &v);
            g[u].push_back(v);
            din[v]++;
        }

        // 输出结果
        printf("%s\n", toposort() ? "YES" : "NO");
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/81263078
今日推荐