HDU 3342 Legal or Not【拓扑排序】

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10279 Accepted Submission(s): 4802

Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many “holy cows” like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost “master”, and Lost will have a nice “prentice”. By and by, there are many pairs of “master and prentice”. But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it’s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian’s master and, at the same time, 3xian is HH’s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the “master and prentice” relation is transitive. It means that if A is B’s master ans B is C’s master, then A is C’s master.

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y’s master and y is x’s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,…, N-1). We use their numbers instead of their names.

Output

For each test case, print in one line the judgement of the messy relationship.
If it is legal, output “YES”, otherwise “NO”.

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO

题意概括:

  有许多大牛,一个大牛可以有许多个徒弟,一个徒弟也可以有许多个师傅,如果a是b的师傅且b是a的师傅,那么这种关系是不合法的,判断给出的关系是否合法。

解题分析:

  拓扑排序,判断是否存在环。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

#define N 110

int d[N], e[N][N];

int topsort(int n)
{
    int i, k, t = n, coun;
    while(t--){
        for(i = coun = 0; i < n; i++){
            if(!d[i]){
                coun++;
                k = i;
            }
        }
        if(!coun) return 0;
        d[k]--;
        for(i = 0; i < n; i++)
            if(e[k][i]) d[i]--;

    }
    return 1;
}

int main()
{
    int i, j, n, t, x, y, flag;
    while(scanf("%d%d", &n, &t), n){
        memset(d, 0, sizeof(d));
        memset(e, 0, sizeof(e));
        while(t--){
            scanf("%d%d", &x, &y);
            if(!e[x][y]) d[y]++;
            e[x][y] = 1;
        }
        if(topsort(n)) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/k_young1997/article/details/80183633
今日推荐