TOJ 3650 Legal or Not 拓扑排序

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/TheWise_lzy/article/details/81239797

3650: Legal or Not

描述

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

输入

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

输出

For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".

样例输入

3 2
0 1
1 2
2 2
0 1
1 0
0 0

样例输出

YES
NO

拓扑排序,模板走一下。

#include <iostream>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <sstream>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <cmath>
#define nmax 200
using namespace std;
vector<int> v[nmax];
int indegree[nmax];
int n;

void topsort()
{
    queue<int> q;
    for(int i=0;i<n;i++)
    {
    	if(!indegree[i])
    	q.push(i);
    }
    int ans=0;
    while(!q.empty())
    {
    	int qq=q.front();
    	q.pop();
    	ans++;
    	for(int i=0;i<v[qq].size();i++)
    	{
	    	indegree[v[qq][i]]--;
	    	if(indegree[v[qq][i]]==0)
	    	q.push(v[qq][i]);
	    }
    }
    if(ans<n)
        printf("NO\n");
    else
        printf("YES\n");
}
int main()
{
    int m,a,b,i;
    while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==0&&m==0)break;
		memset(indegree,0,sizeof(indegree));
		memset(v,0,sizeof(v));
        for(i=0;i<m;i++)
		{
            scanf("%d%d",&a,&b);
            indegree[b]++;
            v[a].push_back(b);
        }
        topsort();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/TheWise_lzy/article/details/81239797
今日推荐