hdu3342(拓扑排序判断环)

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10447    Accepted Submission(s): 4904


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

Sample Input
 
  
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

Sample Output
 
  
YES

NO

题意不多说,判断环,无向图用并查集,有向图用拓扑;

有向图判断有没有环,利用节点数和边数的关系,一步步去除如度为0的节点,可以完全去除说明没有环。反之亦然。

#include<bits/stdc++.h>
using namespace std;

int n,m,a,b;
vector<int> v[105];
int in[105],vis[105];
int main()
{
	while(~scanf("%d%d",&n,&m),n)
	{
		for(int i=0; i<103; i++)v[i].clear();
		memset(in,0,sizeof(in));
		memset(vis,0,sizeof(vis));
		for(int i=0; i<m; i++)
		{
			scanf("%d%d",&a,&b);
			v[a].push_back(b);
			in[b]++;
		}
		int count=n;
		queue<int> q;
		for(int i=0; i<n; i++)
		{
			if(in[i]==0)
			{
				q.push(i);
				vis[i]=1;
			}
		}
		while(!q.empty())
		{
			int k=q.front();
			count--;
			q.pop();
			for(int i=0; i<v[k].size(); i++)
			{
				int x=v[k][i];
				in[x]--;
				if(in[x]==0&&!vis[x])
				{
					q.push(x);
					vis[x]=1;
				}
			}
		}
		if(count==0)printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/yu121380/article/details/81000538