HDU 3342 Legal or Not

Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not? 

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0. 
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

Output

For each test case, print in one line the judgement of the messy relationship. 
If it is legal, output "YES", otherwise "NO".

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO

 源码

#include<iostream>
#include<cstring>
using namespace std;
#define MAXN 1210
bool G[MAXN][MAXN];
int vis[MAXN];
int n,m,num;
void TopologicalSort(){
	num=0;
	for(int i=0;i<n;i++){
		for(int j=0;j<n;j++){
			if(!vis[j]){
				vis[j]--;
				num++;
				for(int k=0;k<n;k++){
					if(G[j][k]){
						G[j][k]=0;
						vis[k]--;
					}
				}
				break;
			}
		}
	}
	if(num!=n) cout<<"NO"<<endl;
	else cout<<"YES"<<endl;
}
int main(){
	while(cin>>n>>m&&(n&&m)){
		memset(G,0,sizeof(G));
		memset(vis,0,sizeof(vis));
		int x,y;
		for(int i=0;i<m;i++){
			cin>>x>>y;
			if(!G[x][y]){//这道题的数据里有数据重复的情况,一旦数据重复,vis数组就会多算一次
						 //最后导致函数调用时,num会多算一次,最终结果错误 
				G[x][y]=1;
				vis[y]++;
			}
		}
		TopologicalSort();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/HPU_LY/article/details/81415396
今日推荐