【拓扑排序】HDOJ 3342 Legal or Not

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10349    Accepted Submission(s): 4844


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

Sample Input
 
  
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

Sample Output
 
  
YES NO
 

Author
QiuQiu@NJFU
 

Source
 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1285 2647 3333 3339 3341 


图论的题目,包含MST、最短路,拓扑排序等等。

本题是利用拓扑排序来判定某一图中是否含有环。

代码模板比较简单:

#include<iostream>
#include<string.h>
#include<algorithm>
#include<stdio.h>
#include<queue>
#include<vector>
using namespace std;
vector<int> edge[501];//用vector模拟链接 邻接链表来表达图结构
queue<int> Q;//保存入度为0的节点,队列本身与拓扑排序原理无关
int inDegree[501];//保存入度
int n,m;
int main(){
	scanf("%d%d",&n,&m);
	while(n!=0&&m!=0){
		//初始化
		for(int i=0;i<n;i++){
			inDegree[i]=0;
			edge[i].clear();
		}
		while(!Q.empty()){
			Q.pop();
		}
		//处理输入
		for(int i=0;i<m;i++){
			int a,b;
			scanf("%d%d",&a,&b);
			inDegree[b]++;
			edge[a].push_back(b);
		}
		//拓扑排序
		int cnt=0;
		for(int i=0;i<n;i++){
			if(inDegree[i]==0)
				Q.push(i);
		}
		while(!Q.empty()){
			int t=Q.front();//新的拓扑排序点
			Q.pop();
			cnt++;
			//“删除”以t为弧尾的边
			for(int i=0;i<edge[t].size();i++){
				inDegree[edge[t][i]]--;
				if(inDegree[edge[t][i]]==0){
					Q.push(edge[t][i]);
				}
			} 
		}
		if(cnt==n)
			printf("YES\n");
		else
			printf("NO\n");
		scanf("%d%d",&n,&m);
	}

}

猜你喜欢

转载自blog.csdn.net/qq_33837704/article/details/80529815
今日推荐