拓扑排序--Legal or Not

Legal or Not

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0. 
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

Output

For each test case, print in one line the judgement of the messy relationship. 
If it is legal, output "YES", otherwise "NO".

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO

测试样例分析:

#include<stdio.h>
#include <string.h>
#define MAX 110

int G[MAX][MAX];
int in[MAX];
int n,m;
int flag;//用于标记是否存在环 

void topo(){
    flag=1;//flag=1表示无环,flag=0表示有环 
    for(int i = 0;i<n;i++){
    	int j;
        for(j = 0;j<n;j++){//找入度为0的点
            if(in[j]==0){
                in[j]--; //in[j] = -1表示已经搞过该点了 
                for(int k = 0;k<n;k++)//与入度为0的点相连的点入度--
                    if(G[j][k]) //j-->k 
                        in[k]--;//k点的入度-1 
                break;//每次找到就break掉
            }
        }
        if(j==n){//扫过所有点,若没找到找入度为0的点时,说明有环
            flag = 0;
            break;
        }
    }
	return ; 
}
 
int main(){
    while(scanf("%d%d",&n,&m)!=EOF){//n个人,m对关系 
    	int x,y;
    	if(n==0&&m==0) break; 
		//初始化 
    	memset(G,0,sizeof(G));
    	memset(in,0,sizeof(in));
    	for(int i = 0;i<m;i++){
        	scanf("%d%d",&x,&y);
        	if(!G[x][y]){
            	G[x][y]=1;//x-->y
            	in[y]++;//入度++
        	}
   		}
        topo();
        if(flag)
        	printf("YES\n");
    	else
        	printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40626497/article/details/81161646
今日推荐