Legal or Not

问题 : Legal or Not

时间限制: 1 Sec   内存限制: 32 MB

题目描述

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

输入

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

输出

For each test case, print in one line the judgement of the messy relationship.If it is legal, output "YES", otherwise "NO".

样例输入

4 3
0 1
1 2
2 3
3 3
0 1
1 2
2 0
0 1

样例输出

YES
NO

解题思路

这道题说的就是判断给出的关系是否合法。这道题不算是太难,就是判断一下利用给出数对能否组成一个环,如果能,说明他们的关系不合法,否则合法,例如A是C的主人,C是B的主人,那B就不可能是A的主人,否则就是不合法的。

好了接下来说一下解题方法:可以用搜索的方法,具体的看代码。

#include <stdio.h>
#include <string.h>
int s[110][110], vis[110], temp;//vis是用来标记在之前出现过的数,如果再次出现,证明能组成一个环,就是不合法的
void dfs(int x, int n)
{
	temp = 0;
	vis[x] = 1;
	for (int y = 0; y < n; y++)
	{
		if (s[x][y] && vis[y])
		{
			temp = 1;
			return ;
		}
		if (s[x][y])
		{
			dfs(y, n);
			if (temp)
				return ;
			vis[y] = 0;
		}
	}
}
int main()
{
	int x, y, n, m;
	while (scanf("%d%d", &n, &m), n)
	{
		memset(s, 0, sizeof(s));
		memset(vis, 0, sizeof(vis));
		for (int i = 0; i < m; i++)
		{
			scanf("%d%d", &x, &y);
			s[x][y] = 1;
		}
		dfs(x, n);//这个一定不能从0开始搜索,它不一定会出现0,从它出现过的一个数字就可以
		if (temp)
			puts("NO");
		else puts("YES");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lzyws739307453/article/details/80186729