【HDU 3342】Legal or Not(拓扑排序)

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10348    Accepted Submission(s): 4843


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

Sample Input
 
  
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

Sample Output
 
  
YES NO

拓扑排序的一个功能就是有向图判环,只要所有的点都被存进栈并压出,那么这就是无环图(DAG);

这个题目其实就是判断一个图是不是DAG;

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define MAXN 10050
vector<int> e[MAXN];
int ind[MAXN];
int main()
{
    ios::sync_with_stdio(0);
    int n,m;
    while(cin>>n>>m&&n&&m)
    {
        queue<int> q;
        for(int i=0;i<n;i++)
        {
            e[i].clear();
            ind[i]=0;
        }
        int a,b;
        for(int i=0;i<m;i++)
        {
            cin>>a>>b;
            e[a].push_back(b);
            ind[b]++;
        }
        for(int i=0;i<n;i++)
        {
            if(!ind[i])
            {
                q.push(i);
            }
        }
        int ans=0;
        while(!q.empty())
        {
            int u=q.front();
            q.pop();
            ans++;
            for(int i=0;i<e[u].size();i++)
            {
                ind[e[u][i]]--;
                if(!ind[e[u][i]])
                {
                    q.push(e[u][i]);
                }
            }
        }
        if(ans==n) puts("YES");
        else puts("NO");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/duanghaha/article/details/80522441
今日推荐