HDU-2844Coins(多重背包)

Coins

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

 

Output
For each test case output the answer on a single line.

 

Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

 

Sample Output
8
4
 

题意:给你给你n个硬币,第i个硬币价值a[i]有c[i]个,问可以组成不超过m的多少个数?

思路:多重背包,判断一个那些数可以被组成,最后跑一遍.

代码:

#include<bits/stdc++.h>
#define mem(a,b) memset(a,b,sizeof(a))
#define mod 1000000007
using namespace std;
typedef long long ll;
const int maxn = 2e5+5;
const double eps = 1e-12;
const int inf = 0x3f3f3f3f;
map<int,int>::iterator it;

int n,m;
int a[maxn],c[maxn];
int dp[maxn];

int main()
{
	while(~scanf("%d %d",&n,&m)&&(n||m))
	{
		mem(dp,0);
		for(int i = 1;i<= n;i++)
			scanf("%d",&a[i]);
		for(int i = 1;i<= n;i++)
			scanf("%d",&c[i]);
		
		dp[0] = 1;
		for(int i = 1;i<= n;i++)
		{
			for(int j = 1;j<= c[i];j<<= 1)
			{
				for(int k = m;k>= a[i]*j;k--)
				{
					if(dp[k-a[i]*j])
						dp[k] = 1;
				}
				c[i]-= j;
			}
			
			if(c[i] == 0) continue;
			for(int k = m;k>= a[i]*c[i];k--)
			{
				if(dp[k-a[i]*c[i]])
					dp[k] = 1;
			}
		}
		
		int ans = 0;
		for(int i = 1;i<= m;i++)
			ans+= dp[i];
		
		printf("%d\n",ans);
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/nka_kun/article/details/81188395