Coins HDU - 2844-完全背包

Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int n,m,a[105],c[105];
bool dp[100005];
int ans[100005];
int  main()
{
    
    
    while(scanf("%d%d",&n,&m)!=EOF&&(n!=0&&m!=0))
    {
    
    
        memset(dp,false,sizeof(dp));
        for(int i=0; i<n; i++)
        {
    
    
            scanf("%d",&a[i]);
        }
        for(int i=0; i<n; i++)
        {
    
    
            scanf("%d",&c[i]);
        }
        dp[0]=true;
        for(int i=0; i<n; i++)
        {
    
    
            memset(ans,0,sizeof(ans));  //计数置零;
            for(int j=a[i]; j<=m; j++)
            {
    
    
                if(dp[j-a[i]]&&!dp[j]&&ans[j-a[i]]<c[i])  //把数量放在外边,优化了一个for循环;
                {
    
    
                    dp[j]=true;
                    ans[j]=ans[j-a[i]]+1;
                }
            }
        }
        int sum=0;
        for(int i=m; i>0; i--)
        {
    
    
            if(dp[i])
            {
    
    
                sum++;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/JdiLfc/article/details/109003072