HDU-2844 Coins 简单多重背包

Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4

题目大意:有不同种类的硬币,每种不止一个,求最多可以组合出多少种不大于m的总价值。
思路:直接多重背包,加一个统计操作即可。

AC代码

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <iostream>
using namespace std;

int v[105],w[105],s[100005],dp[100005];

int main() {
    int n, m;
    while (cin >> n >> m && (n || m)) {
        for (int i = 0; i < n; i++)
            cin >> v[i];
        for (int i = 0; i < n; i++)
            cin >> w[i];
        memset(dp, 0, sizeof(dp));
        dp[0] = 1;
        int ans = 0;
        for (int i = 0; i < n; i++) {
            memset(s, 0, sizeof(s));
            for (int j = v[i]; j <= m; j++) {
                if (!dp[j] && dp[j - v[i]] && s[j - v[i]] < w[i]) {
                    dp[j] = 1;
                    s[j] = s[j - v[i]] + 1;
                    ans++;
                }
            }
        }
        cout << ans << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42764823/article/details/88614988