HDU 2844 Coins(多重背包)

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18573    Accepted Submission(s): 7308


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
 
  
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
 
Sample Output
 
  
8
4

题意:给的这些硬币中能够组合成1—m的方案数。多重背包,记录dp[ i ]==i 的个数

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[100007],n,m,a[105],c[105],count;
void zeropack(int cost,int value)
{
    for(int i=m;i>=cost;i--)
        dp[i]=max(dp[i],dp[i-cost]+value);
}
void completepack(int cost,int value)
{
    for(int i=cost;i<=m;i++)
        dp[i]=max(dp[i],dp[i-cost]+value);
}
void multipack(int cost,int value,int num)
{
    if(num*cost>=m)
    {
        completepack(cost,value);
        return;
    }
    int k=1;
    while(k<num)
    {
        zeropack(k*cost,k*value);
        num-=k;
        k*=2;
    }
    zeropack(num*cost,num*value);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0) break;
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        for(int i=1;i<=n;i++) scanf("%d",&c[i]);
        memset(dp,0,sizeof(dp));
        count=0;
        for(int i=1;i<=n;i++)
        {
            multipack(a[i],a[i],c[i]);
        }

        for(int i=1;i<=m;i++)
        {
            if(dp[i]==i) count++;
        }
        printf("%d\n",count);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/bbhhtt/article/details/80289108