1002. A+B for Polynomials(25)—PAT 甲级

This time,you are supposed to find A+B where A+B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a
polynomial: K N1 aN1 N2 aN2 ... Nk aNK, Where k is the number of nonezero terms in the polynomial, Ni and aNi (i = 1 , 2,..., k) are the exponents and coefficients, respectively . It is given that 1< = K < = 10,0< = NK < ... < N2 < N1 <= 1000.

Output

For each test case you should output the sum of A and B in one line, with the same format asthe input . Notice
that there must be No extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2 2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

题目大意:多项式合并同类项,按输入格式输出最后多项式的项数、各项的指数和系数。
分析:构造一个整型数组存放多项式的系数,输入时将相同指数的系数累加,如果累加之前数组存放的值为0,那么多项式的项数加1;如果累加之后等于0,那么多项式的项数减一。注意:多项式的指数都是整数,不要瞎想了~

#include <iostream>
using namespace std;

double s[1005]={0};
int main() {
    int k,n,time=2,count=0; 
    double ak;
    while(time--){
        scanf("%d",&k);
        while(k--){
            scanf(" %d %lf",&n,&ak);
            if(s[n]==0)count++;
            s[n]+=ak;
            if(s[n]==0)count--;
        }
    }
    printf("%d",count);
    for(int i=1005;i>=0;i--){
        if(s[i]!=0){
            printf(" %d %.1lf",i,s[i]);
        }
    }
    printf("\n");
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Endlessp162096/p/8970931.html