HDU 1081 To The Max

Problem Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

Input

The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

Sample Output

15

题意

求最大子矩阵和

CODE

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 200
int main()
{
    int a[N][N];
    int k,i,j,n,sum,maxx,i2,i1;
    while(scanf("%d",&n)!=EOF){
        for(i=0;i<=n;++i)a[0][i]=a[i][0]=0;
        for(i=1;i<=n;++i){
            for(j=1;j<=n;++j){
                scanf("%d",&a[i][j]);
                a[i][j]+=a[i-1][j];
            }
        }
        maxx = -129;
        for(i1=0;i1<n;++i1){
            for(i2=i1+1;i2<=n;++i2){
                sum = 0;
                for(k=1;k<=n;++k){
                    if(sum<=0) sum = (a[i2][k]-a[i1][k]);
                    else sum += (a[i2][k]-a[i1][k]);
                    if(sum>maxx) maxx = sum;
                }
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ac__go/article/details/78395706
今日推荐